Linux Mint 18 ja ID-kaart

30+ lugude järgmist osa kirjutades sai paigaldatud Linux Minti järgmine versioon. Ubuntu 16.04 LTS Xenial Xerus on juba aprillikuust saati väljas, sellel põhinev Mint 18 aga on hetkel veel beetastaadiumis. Kõik muu näib töötavat ilusti.

Eesti ID-kaardil on isegi vajalik pakk (esteid) varamutes täiesti olemas, aga paigaldus takerdub sõltuvuste taha ega õnnestu. Seega tegin hädapärase lahenduse: muutsin ametliku skriptifaili paar rida ära (lõpust 187. realt – versiooninumbri 17-lt 18-ks ja trusty xenial-iks; minu failiversioon on saadaval siit).

Lahendus seega:

  • Paigalda Chromiumi veebilehitseja (Firefoxi kummitab juba pikka aega ID-kaardi juures probleem turvaühenduse sisseseadmisega) – paigalda chromium-browser ja soovi korral ka tõlkepakk chromium-browser-l10n (kui soovid eestikeelset lehitsejat).
  • Laadi alla kas minu skript või ametlik ja tee ise vastavad muudatused (vt eespool).
  • Ava terminal, mine allalaadimiste kataloogi (cd Allalaadimised) ja käivita skript (minu skripti puhul käsuga sh install-open-eid_LinuxMint18.sh).
  • Vajuta kaks korda Enter-klahvi – esiteks seal, kus öeldakse “Press Enter to continue, CTRL-C to cancel” ja teiseks seal, kus tuleb “Do you want to continue? [Y/n]” – nende vahepeal küsitakse tõenäoliselt ka parooli (kuna paigaldus toimub haldusrežiimis).
  • Kindluse mõttes tee arvutile taaskäivitus.

Kommenteerimine on suletud.